Unselected
VE 120

Ref: 8213119

VE 120

2012

Year of commercialization: 2012

Unselected

I have a problem

I'm having a problem with the level of resistance

1. I can't adjust the level of resistance
           => The cable is not properly connected
Disassemble the handlebar post and check that the cable is properly connected
           => Make sure the black plastic block on the lower cable has been removed

2. The 1st level of resistance is abnormally hard
           => The cable is not properly connected
Disassemble the handlebar post and check that the cable is properly connected

My bike makes noise

The screws are loose
           => Tighten all visible screws

'Err' appear on console

VE 120
My console doesn't turn on

1. Assembly problem
=> At the back of the console
Refer to the instructions to check that the console has been connected correctly
=> At the connection between the two tubes
Refer to the instructions to check that the cables have been connected correctly

2. Electrical problem
=> Your bike works with batteries
Check that the batteries are properly positioned with the correct +/- polarity. If the problem persists, start again with new batteries
=> Your bike is plugged into the main socket
Check if the adaptor is correctly connected to the bike and plugged into the main sokcet and make sure that it works

3. Problem in use
Information: the console will not switch on if you are using batteries and the mains power at the same time

VE 120
I'm having a problem with the pedals

1. I can't assemble the pedals
           => Assembly problem
Make sure to use the right pedal (marked with \"R\") on the right side and the left pedal (marked with \"L\") on the left side

2. I hear a noise when pedaling
           => Make sure that all pedales have been properly mounted
Make sure that all washers have been properly mounted (as per the instructions) and that all screws are tight enough

My bike makes a clicking noise on every pedal turn

The pedals are not tight enough
            => Loosen the pedals 1 tour and tighten them back up as hard as possible

I hear a noise when pedaling

I hear a noise when pedaling
           => Make sure that all pedales have been properly mounted (as per the instructions)

The console displays speed and distance with the wrong unit (km/mi)

Calibration problem
           => Check that the switch at the back of the console is in the position MI for miles and KM for kilometres
Press RESET to validate

Unselected

Manual and software

Unselected
VE 120

Would you like further help?

Click on "Request assistance"